Our Network provider (Cloudflare) has informed us that a fix has been implemented and believes the incident is now resolved. We are continuing to monitor for errors to ensure all services are back to normal.
Posted Nov 18, 2025 - 14:45 UTC
Update
We are continuing to investigate this issue.
Posted Nov 18, 2025 - 13:34 UTC
Investigating
We are continuing to investigate this issue.
Posted Nov 18, 2025 - 12:45 UTC
Monitoring
The network provider (Cloudflare) has advised us that services are recovering, but customers may continue to experience higher-than-normal error rates as we continue our remediation efforts.
Posted Nov 18, 2025 - 12:31 UTC
Update
We are continuing to investigate this issue.
Posted Nov 18, 2025 - 12:12 UTC
Update
We are continuing to investigate this issue.
Posted Nov 18, 2025 - 12:09 UTC
Investigating
Our Network provider (Cloudflare) is reporting an Issue with its Backend system. Some users may be experiencing an issue accessing our services.
Posted Nov 18, 2025 - 11:42 UTC
This incident affected: Portal, Reflows, Review, API, and Authentication and User Management.