Degraded performance of User Management

Incident Report for SuperByte

Resolved

This incident has been resolved.
Posted Apr 12, 2024 - 12:55 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 12, 2024 - 12:52 UTC

Identified

We have identified an issue that is causing role changes to take longer to process, we are working on a fix for this now
Posted Apr 12, 2024 - 12:18 UTC
This incident affected: Authentication and User Management.